Autoptimize

Das WordPress-Plugin Autoptimize optimiert die Website, fügt CSS und JavaScript-Code zusammen und komprimiert diesen. Eliminiert die “above the fold”-Fehlermeldung und die Versioning-Fehlermeldung von Google PageSpeed Insights. Entfernt unnötigen Code, optimiert Google Fonts, beschleunigt letztlich die Seitenladezeit erheblich.

Download

Autoptimize

Versioning-Fehlermeldung

Google PageSpeed Insights bemängelt bei JavaScript die Übergabe eines Parameters für die Programmversion, nämlich den Parameter ver=. Erkenntlich am Fragezeichen am Ende des Scriptaufrufs.

Versioning-Fehlermeldung

Das Fragezeichen signalisiert die Parameterübergabe, d. h. der Aufruf ist dynamisch und darf deshalb nicht gecached werden, was der Browser richtigerweise auch nicht macht. Da aber der Versionsparameter in der Praxis keine Funktion hat, bewertet Google PageSpeed Insight dies als Mangel.

Also weg damit!

Autoptimize | Einstellungen | Extras

Ver-Parameter löschen

“Above the fold”-Fehlermeldung

Die meisten dieser “above the fold”-Fehlermeldungen von Google PageSpeed Insights werden bereits durch die Installation des Autoptimize-Plugins automatisch eliminiert, bis auf die Fehlermeldung durch sein eigenes CSS. Google PSI quittiert dies durch eine Fehlermeldung wie

http://www.domain.xx/wp-content/cache/autoptimize/css/autoptimize_*********************.css

Ganz klar, weil das Autoptimize-Plugin noch nicht vollständig konfiguriert ist. Man muß nämlich den “above the fold” CSS-Code als Inline-CSS im HEAD-Bereich des HTML-Dokuments einfügen und das restliche CSS, nachdem die Seite schon geladen ist, am Ende der Seite einfügen. Erst dann verschwindet auch diese Fehlermeldung.

Above the fold-Fehlermeldung

jquery.js

Ist die weltweit meistverwendete JavaScript-Bibliothek, läuft auf ca. 50% aller Websites. Wird von Autoptimize nicht optimiert, da viele beliebte Plugins Inline JS erzeugen, das nicht zusammengefügt wird (wegen möglicher Probleme mit der Cachegröße bei einmaligem Code in Inline JS), welches von jquery abhängig ist. Das Ausschließen von jquery.js stellt sicher, dass die meisten Websites auf Anhieb funktionieren.

Deshalb wird Google PSI eine “above the fold”-Fehlermeldung ausgeben – Abhilfe schafft das WordPress-Plugin Async Javascript.

Screenshots

Allgemeine Einstellungen

Autoptimize Einstellungen

Einstellungen – Extras

Autoptimize Einstellungen/Extras